package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(((http|https):\/\/)+[www.])?\s*\S+\s*(.com|.es|.net|.org|.co)$`)
var str = `www.googlemcom
http://.google.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}