re = /^(?!ss|ww|.[iou]|[iou].)([a-z]{2})[-\s]?(\d{3})[-\s]?(?!ss|ww|.[iou]|[iou].)([a-z]{2})$/i
str = 'AA-123-BB'
# Print the match result
str.match(re) do |match|
puts match.to_s
end