const regex = /^(?!ss|ww|.[iou]|[iou].)([a-z]{2})[-\s]?(\d{3})[-\s]?(?!ss|ww|.[iou]|[iou].)([a-z]{2})$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!ss|ww|.[iou]|[iou].)([a-z]{2})[-\\s]?(\\d{3})[-\\s]?(?!ss|ww|.[iou]|[iou].)([a-z]{2})$', 'i')
const str = `AA-123-BB`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}