$re = '/^(?!ss|ww|.[iou]|[iou].)([a-z]{2})[-\s]?(\d{3})[-\s]?(?!ss|ww|.[iou]|[iou].)([a-z]{2})$/i';
$str = 'AA-123-BB';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);