re = /:\s*(\w.*?)\s*-/
str = 'Planning Unit: Inbound Contacts - Tuesday, 27/03/2018'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end