package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:\s*(\w.*?)\s*-`)
var str = `Planning Unit: Inbound Contacts - Tuesday, 27/03/2018`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}