using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\s*(\w.*?)\s*-";
string input = @"Planning Unit: Inbound Contacts - Tuesday, 27/03/2018";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}