re = /([^\)]+)\(([^\)]+)\)([^\()]+)\(([^\)]+)\)/
str = 'AMOUR FOU(35491) - 0.3(35497)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end