package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\)]+)\(([^\)]+)\)([^\()]+)\(([^\)]+)\)`)
var str = `AMOUR FOU(35491) - 0.3(35497)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}