$re = '/([^\)]+)\(([^\)]+)\)([^\()]+)\(([^\)]+)\)/';
$str = 'AMOUR FOU(35491) - 0.3(35497)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);