// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xim){%\strans\s+%}\s(.*?)\s+{%\sendtrans\s%}").unwrap();
let string = "{{ param1 | trans }} {% trans %} businesshours.others.until {% endtrans %} {{ param2 | trans }}: {{ business_hours_params.businessHoursParam3 }} – {{ business_hours_params.businessHoursParam4 }} {% trans %} businesshours.posttext {% endtrans %}<br>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}