package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im){%\strans\s+%}\s(.*?)\s+{%\sendtrans\s%}`)
var str = `{{ param1 | trans }} {% trans %} businesshours.others.until {% endtrans %} {{ param2 | trans }}: {{ business_hours_params.businessHoursParam3 }} – {{ business_hours_params.businessHoursParam4 }} {% trans %} businesshours.posttext {% endtrans %}<br>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}