using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{%\strans\s+%}\s(.*?)\s+{%\sendtrans\s%}";
string input = @"{{ param1 | trans }} {% trans %} businesshours.others.until {% endtrans %} {{ param2 | trans }}: {{ business_hours_params.businessHoursParam3 }} – {{ business_hours_params.businessHoursParam4 }} {% trans %} businesshours.posttext {% endtrans %}<br>";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.IgnoreCase | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}