// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[ах]+\)*[\s]*$").unwrap();
let string = "sdf - 01:10:10 10:10:10 asd
LUL LUL LUL
Аххахах
lul
clips asfsf
фыв клип фыв ф
ахахаха
хахахаах
ахаха
ахаха)
ахахаххх))))
ахахаххх)))) ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}