import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"""
(?(DEFINE)
(?<u>[А-ЯЁ])
(?<l>[а-яё])
(?<b>
(?<=^)(?=[а-яёА-ЯЁ])
|
(?<=[а-яёА-ЯЁ])(?=$)
|
(?<=[^а-яёА-ЯЁ])(?=[а-яёА-ЯЁ])
|
(?<=[а-яёА-ЯЁ])(?=[^а-яёА-ЯЁ])
)
)
(?P>b)
(?:
(?P>l)+(?P>u)(?P>l)+
|
(?P>u)(?P>l)+
|
(?P>l)+(?P>u)
)
(?P>b)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"Русское слово имЕющее роВНо ОДНу заглавнуЮ"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)