#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?umx)(?(DEFINE)" & @CRLF & _
" (?<u>[А-ЯЁ])" & @CRLF & _
" (?<l>[а-яё])" & @CRLF & _
" (?<b>" & @CRLF & _
" (?<=^)(?=[а-яёА-ЯЁ])" & @CRLF & _
" |" & @CRLF & _
" (?<=[а-яёА-ЯЁ])(?=$)" & @CRLF & _
" |" & @CRLF & _
" (?<=[^а-яёА-ЯЁ])(?=[а-яёА-ЯЁ])" & @CRLF & _
" |" & @CRLF & _
" (?<=[а-яёА-ЯЁ])(?=[^а-яёА-ЯЁ])" & @CRLF & _
" )" & @CRLF & _
")" & @CRLF & _
"(?P>b)" & @CRLF & _
" (?:" & @CRLF & _
" (?P>l)+(?P>u)(?P>l)+" & @CRLF & _
" |" & @CRLF & _
" (?P>u)(?P>l)+" & @CRLF & _
" |" & @CRLF & _
" (?P>l)+(?P>u)" & @CRLF & _
" )" & @CRLF & _
"(?P>b)"
Local $sString = "Русское слово имЕющее роВНо ОДНу заглавнуЮ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")