package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<u>[А-ЯЁ])
(?<l>[а-яё])
(?<b>
(?<=^)(?=[а-яёА-ЯЁ])
|
(?<=[а-яёА-ЯЁ])(?=$)
|
(?<=[^а-яёА-ЯЁ])(?=[а-яёА-ЯЁ])
|
(?<=[а-яёА-ЯЁ])(?=[^а-яёА-ЯЁ])
)
)
(?P>b)
(?:
(?P>l)+(?P>u)(?P>l)+
|
(?P>u)(?P>l)+
|
(?P>l)+(?P>u)
)
(?P>b)`)
var str = `Русское слово имЕющее роВНо ОДНу заглавнуЮ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}