re = /(e|d|b)-(heme|gome|jome)-([^\/]+)(?!\/)/
str = '/jome/stat/d-heme-sdfsdf/ertert
/jome/stat/d-heme-sdfsdf
/jome/stat/d-gome-sdfsdf/qeqwe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end