const regex = /(e|d|b)-(heme|gome|jome)-([^\/]+)(?!\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(e|d|b)-(heme|gome|jome)-([^\\\/]+)(?!\\\/)', 'g')
const str = `/jome/stat/d-heme-sdfsdf/ertert
/jome/stat/d-heme-sdfsdf
/jome/stat/d-gome-sdfsdf/qeqwe`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}