#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(e|d|b)-(heme|gome|jome)-([^\/]+)(?!\/)"
Local $sString = "/jome/stat/d-heme-sdfsdf/ertert" & @CRLF & _
"/jome/stat/d-heme-sdfsdf" & @CRLF & _
"/jome/stat/d-gome-sdfsdf/qeqwe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")