const regex = new RegExp('\\b[(]?(?P<areaCode>\\d{3})[)]?[ .-](?P<phone>\\d{3}[ .-]\\d{4})\\b', 'gs')
const str = `YES
(800)-555-1234
212 777.6789
Phone: 800 555-6879.
NO
1234567891011
abc def-ghij
800 def.ghij
Phone: 1234567891011`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}