#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\b[(]?(?P<areaCode>\d{3})[)]?[ .-](?P<phone>\d{3}[ .-]\d{4})\b"
Local $sString = "YES" & @CRLF & _
"(800)-555-1234" & @CRLF & _
"212 777.6789" & @CRLF & _
"Phone: 800 555-6879." & @CRLF & _
"" & @CRLF & _
"NO" & @CRLF & _
"1234567891011" & @CRLF & _
"abc def-ghij" & @CRLF & _
"800 def.ghij" & @CRLF & _
"Phone: 1234567891011"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")