using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[(]?(?P<areaCode>\d{3})[)]?[ .-](?P<phone>\d{3}[ .-]\d{4})\b";
string input = @"YES
(800)-555-1234
212 777.6789
Phone: 800 555-6879.
NO
1234567891011
abc def-ghij
800 def.ghij
Phone: 1234567891011";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}