const regex = /^\s*[\r\n]/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*[\\r\\n]', 'img')
const str = `# H1
## H2
### H3
# A First Level Header
## Second Level Header
Now is the time for all good men to come to the aid of their country. This is just a regular paragraph.
The quick brown fox jumped over the lazy dog's back.
*The* quick brown fox jumped over the lazy dog's back.
**The** quick brown fox jumped over the lazy dog's back.
\`The\` quick brown fox jumped over the lazy dog's back.
[The]() quick brown fox jumped over the lazy dog's back.
### Header 3
> This is a blockquote.
>
> This is the second paragraph in the blockquote.
>
> ## This is an H2 in a blockquote`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);