import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*[\\r\\n]";
final String string = "# H1\n"
+ " ## H2\n"
+ "### H3\n\n"
+ "# A First Level Header\n\n"
+ "## Second Level Header\n\n"
+ "Now is the time for all good men to come to the aid of their country. This is just a regular paragraph.\n\n"
+ "The quick brown fox jumped over the lazy dog's back.\n\n"
+ "*The* quick brown fox jumped over the lazy dog's back.\n\n"
+ "**The** quick brown fox jumped over the lazy dog's back.\n\n"
+ "`The` quick brown fox jumped over the lazy dog's back.\n\n"
+ "[The]() quick brown fox jumped over the lazy dog's back.\n\n"
+ "### Header 3\n\n"
+ "> This is a blockquote.\n"
+ "> \n"
+ "> This is the second paragraph in the blockquote.\n"
+ ">\n"
+ "> ## This is an H2 in a blockquote";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}