# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*[\r\n]//img;t' <<< "# H1
## H2
### H3
# A First Level Header
## Second Level Header
Now is the time for all good men to come to the aid of their country. This is just a regular paragraph.
The quick brown fox jumped over the lazy dog's back.
*The* quick brown fox jumped over the lazy dog's back.
**The** quick brown fox jumped over the lazy dog's back.
`The` quick brown fox jumped over the lazy dog's back.
[The]() quick brown fox jumped over the lazy dog's back.
### Header 3
> This is a blockquote.
>
> This is the second paragraph in the blockquote.
>
> ## This is an H2 in a blockquote"