import Foundation
let pattern = #" *"(\w+)": ("?[^,"]*"?)[,|,\n]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"ID": 26,
"MenuName": "测点数据管理",
"PLevel": 2,
"Url": "pages/datamanage/sensor_group/index.html",
"NewTab": 0,
"IconName": "",
"ParentID": 23,
"OrderBy": 5,
"Remark": "",
"MenuType": 2,
"RoleID": 1,
"PagePower": 1,
"MenuID": "26",
"ButtonName": "添加数据",
"ButtonID": "addSensorOrgData",
"FunctionName": "addSensorOrgDataByID",
"FunctionController": "sensordata",
"OrderBy": 5,
"RoleID": 1,
"MenuType": 3,
"MenuID": 1,
"ParentID": 26,
"MenuName": "添加数据",
"PagePower": 1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)