$re = '/ *"(\w+)": ("?[^,"]*"?)[,|,\n]/m';
$str = ' "ID": 26,
"MenuName": "测点数据管理",
"PLevel": 2,
"Url": "pages/datamanage/sensor_group/index.html",
"NewTab": 0,
"IconName": "",
"ParentID": 23,
"OrderBy": 5,
"Remark": "",
"MenuType": 2,
"RoleID": 1,
"PagePower": 1,
"MenuID": "26",
"ButtonName": "添加数据",
"ButtonID": "addSensorOrgData",
"FunctionName": "addSensorOrgDataByID",
"FunctionController": "sensordata",
"OrderBy": 5,
"RoleID": 1,
"MenuType": 3,
"MenuID": 1,
"ParentID": 26,
"MenuName": "添加数据",
"PagePower": 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);