// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m) *"(\w+)": ("?[^,"]*"?)[,|,\n]"#).unwrap();
let string = " \"ID\": 26,
\"MenuName\": \"测点数据管理\",
\"PLevel\": 2,
\"Url\": \"pages/datamanage/sensor_group/index.html\",
\"NewTab\": 0,
\"IconName\": \"\",
\"ParentID\": 23,
\"OrderBy\": 5,
\"Remark\": \"\",
\"MenuType\": 2,
\"RoleID\": 1,
\"PagePower\": 1,
\"MenuID\": \"26\",
\"ButtonName\": \"添加数据\",
\"ButtonID\": \"addSensorOrgData\",
\"FunctionName\": \"addSensorOrgDataByID\",
\"FunctionController\": \"sensordata\",
\"OrderBy\": 5,
\"RoleID\": 1,
\"MenuType\": 3,
\"MenuID\": 1,
\"ParentID\": 26,
\"MenuName\": \"添加数据\",
\"PagePower\": 1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}