import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(collapse|collapse in)\\]\\s*<(h[2-4])>(.*)<\\/\\2>(.*)\\s*\\[\\/collapse\\]";
final String string = "<p>Bene eros jus neo olim pecus suscipit. </p>\n"
+ "[collapse in] \n"
+ " <h2>titel</h2>\n"
+ "<p>Illum iriure neo populus refoveo.</p> \n"
+ " <h3>titel</h3>\n"
+ "<p>Illum iriure neo populus refoveo.</p> \n"
+ " <h2>titel</h>\n"
+ "<p>Illum iriure neo populus refoveo.</p> \n"
+ "[/collapse]\n"
+ "[collapse] \n"
+ " <h3>titel2</h3>\n"
+ "<p>Illum iriure neo populus refoveo.</p> [/collapse]";
final String subst = "<\\2 data-target=\"#\\3\" data-toggle=\"\\1\">\\3</\\2>\\n<div id=\"\\3\" class=\"collapse\">\\4</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}