#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?Us)\[(collapse|collapse in)\]\s*<(h[2-4])>(.*)<\/\2>(.*)\s*\[\/collapse\]"
Local $sString = "<p>Bene eros jus neo olim pecus suscipit. </p>" & @CRLF & _
"[collapse in] " & @CRLF & _
" <h2>titel</h2>" & @CRLF & _
"<p>Illum iriure neo populus refoveo.</p> " & @CRLF & _
" <h3>titel</h3>" & @CRLF & _
"<p>Illum iriure neo populus refoveo.</p> " & @CRLF & _
" <h2>titel</h>" & @CRLF & _
"<p>Illum iriure neo populus refoveo.</p> " & @CRLF & _
"[/collapse]" & @CRLF & _
"[collapse] " & @CRLF & _
" <h3>titel2</h3>" & @CRLF & _
"<p>Illum iriure neo populus refoveo.</p> [/collapse]"
Local $sSubst = "<\2 data-target="#\3" data-toggle="\1">\3</\2>\n<div id="\3" class="collapse">\4</div>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)