using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(collapse|collapse in)\]\s*<(h[2-4])>(.*)<\/\2>(.*)\s*\[\/collapse\]";
string substitution = @"<\2 data-target=""#\3"" data-toggle=""\1"">\3</\2>\n<div id=""\3"" class=""collapse"">\4</div>";
string input = @"<p>Bene eros jus neo olim pecus suscipit. </p>
[collapse in]
<h2>titel</h2>
<p>Illum iriure neo populus refoveo.</p>
<h3>titel</h3>
<p>Illum iriure neo populus refoveo.</p>
<h2>titel</h>
<p>Illum iriure neo populus refoveo.</p>
[/collapse]
[collapse]
<h3>titel2</h3>
<p>Illum iriure neo populus refoveo.</p> [/collapse]";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}