re = /^[A-Za-z]+[\w\-\:\.\_]+(?!\!\@\#\$\%\^\&\(\)\{\}\[\]\?\`\~\;\"\'\\\/\<\>\+\=\,)*$/
str = 'anchor_12'
# Print the match result
str.match(re) do |match|
puts match.to_s
end