$re = '/^[A-Za-z]+[\w\-\:\.\_]+(?!\!\@\#\$\%\^\&\(\)\{\}\[\]\?\`\~\;\"\'\\\\\/\<\>\+\=\,)*$/';
$str = 'anchor_12';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);