#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[A-Za-z]+[\w\-\:\.\_]+(?!\!\@\#\$\%\^\&\(\)\{\}\[\]\?\`\~\;\"\'\\\/\<\>\+\=\,)*$"
Local $sString = "anchor_12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")