re = /&(#[a-fA-F0-9]{6})((?:-#[a-fA-F0-9]{6})+)((?:&[k-oK-OrR])+)?(.*?)(?=(&#[a-fA-F0-9]{6}|&[a-fA-Fk-oK-OrR0-9])|$)/m
str = '𛈇-#222222-#333333&lTesting text&f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end