import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "&(#[a-fA-F0-9]{6})((?:-#[a-fA-F0-9]{6})+)((?:&[k-oK-OrR])+)?(.*?)(?=(&#[a-fA-F0-9]{6}|&[a-fA-Fk-oK-OrR0-9])|$)";
final String string = "𛈇-#222222-#333333&lTesting text&f";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}