const regex = new RegExp('&(#[a-fA-F0-9]{6})((?:-#[a-fA-F0-9]{6})+)((?:&[k-oK-OrR])+)?(.*?)(?=(&#[a-fA-F0-9]{6}|&[a-fA-Fk-oK-OrR0-9])|$)', 'gm')
const str = `𛈇-#222222-#333333&lTesting text&f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}