re = /^((1\d{2}|2[0-4]\d|25[0-5]|[1-9]?\d)(\.(?=\d)|(?!\d))){4}(\/([12]?\d|3[0-2]))?$/m
str = '10.238.51.19
12.89.119.255/30
12.89.119.25
1.2.3.4/24
0.0.0.0/0
00.00.00.00
0.0.0.0.0
1.1..123
1.1.1234.123
1.1.1.123/
1.1.456.78
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end