use strict;
my $str = '10.238.51.19
12.89.119.255/30
12.89.119.25
1.2.3.4/24
0.0.0.0/0
00.00.00.00
0.0.0.0.0
1.1..123
1.1.1234.123
1.1.1.123/
1.1.456.78
';
my $regex = qr/^((1\d{2}|2[0-4]\d|25[0-5]|[1-9]?\d)(\.(?=\d)|(?!\d))){4}(/([12]?\d|3[0-2]))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}