using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((1\d{2}|2[0-4]\d|25[0-5]|[1-9]?\d)(\.(?=\d)|(?!\d))){4}(/([12]?\d|3[0-2]))?$";
string input = @"10.238.51.19
12.89.119.255/30
12.89.119.25
1.2.3.4/24
0.0.0.0/0
00.00.00.00
0.0.0.0.0
1.1..123
1.1.1234.123
1.1.1.123/
1.1.456.78
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}