re = /(\/\/i(?:s|)\d*\.(?:4cdn|4chan)\.org\/\w+\/(\d+\.(?:jpg|png|gif|webm)))/m
str = 'http://is2.4chan.org/gif/1559559046386.webm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end