package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/\/i(?:s|)\d*\.(?:4cdn|4chan)\.org\/\w+\/(\d+\.(?:jpg|png|gif|webm)))`)
var str = `http://is2.4chan.org/gif/1559559046386.webm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}