import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\/i(?:s|)\\d*\\.(?:4cdn|4chan)\\.org\\/\\w+\\/(\\d+\\.(?:jpg|png|gif|webm)))";
final String string = "http://is2.4chan.org/gif/1559559046386.webm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}