re = /((?<raute>#(?<raute_content>.*))|(?<doubleslashes>\/\/(?<doubleslashes_content>.*))|(?<block>\/\*(?<block_content>[^*]+|\*(?!\/))*+\*\/))/m
str = 'blah
# ein Kommentar
blah blah // ein Kommentar
/*
Ein
Kommentar
Block
*/
blah # ein weiteres Kommentar
blah
/* Zweiter Block
Geht wieder über mehrere Zeilen */
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end