$re = '/((?<raute>#(?<raute_content>.*))|(?<doubleslashes>\/\/(?<doubleslashes_content>.*))|(?<block>\/\*(?<block_content>[^*]+|\*(?!\/))*+\*\/))/m';
$str = 'blah
# ein Kommentar
blah blah // ein Kommentar
/*
Ein
Kommentar
Block
*/
blah # ein weiteres Kommentar
blah
/* Zweiter Block
Geht wieder über mehrere Zeilen */
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);