import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<raute>#(?<raute_content>.*))|(?<doubleslashes>\\/\\/(?<doubleslashes_content>.*))|(?<block>\\/\\*(?<block_content>[^*]+|\\*(?!\\/))*+\\*\\/))";
final String string = "blah\n"
+ "# ein Kommentar\n"
+ "blah blah // ein Kommentar\n\n"
+ "/*\n"
+ " Ein\n"
+ "Kommentar\n"
+ " Block\n\n\n"
+ "*/\n\n"
+ "blah # ein weiteres Kommentar\n\n"
+ "blah\n\n"
+ "/* Zweiter Block\n\n"
+ "Geht wieder über mehrere Zeilen */\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}