// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\s+\$\s*(?P<in_line>[^$]+?)\s*\$\s+|^\s*\${2}\s*(?P<bloc>(?:[^$]{2})*?)\s*\${2})").unwrap();
let string = "Lorem ipsum dolor sit ame $ a = \\{ b, c \\} $ Lorem 100 \\$ ipsum
$$ \\left \\{
\\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\\\y_2 =&2 x_2\\\\y_3 =&x_1 - x_2 + 3 x_3\\end{array}
\\right.
\\Leftrightarrow \\left \\{
\\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\\\8 x_2 =&4 y_2\\\\8 x_3 =&-y_1 + y_2 + 3 y_3\\end{array}
\\right.
$$
Lorem ipsum dolor
$$ \\left \\{
\\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\\\y_2 =&2 x_2\\\\y_3 =&x_1 - x_2 + 3 x_3\\end{array}
\\right.
\\Leftrightarrow \\left \\{
\\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\\\8 x_2 =&4 y_2\\\\8 x_3 =&-y_1 + y_2 + 3 y_3\\end{array}
\\right.
$$
Lorem ipsum dolor $$$ Lorem ipsum dolor $$$. foo sit ame $ a = \\{ b, c \\} $ ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}