using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s+\$\s*(?P<in_line>[^$]+?)\s*\$\s+|^\s*\${2}\s*(?P<bloc>(?:[^$]{2})*?)\s*\${2})";
string input = @"Lorem ipsum dolor sit ame $ a = \{ b, c \} $ Lorem 100 \$ ipsum
$$ \left \{
\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\y_2 =&2 x_2\\y_3 =&x_1 - x_2 + 3 x_3\end{array}
\right.
\Leftrightarrow \left \{
\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\8 x_2 =&4 y_2\\8 x_3 =&-y_1 + y_2 + 3 y_3\end{array}
\right.
$$
Lorem ipsum dolor
$$ \left \{
\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\y_2 =&2 x_2\\y_3 =&x_1 - x_2 + 3 x_3\end{array}
\right.
\Leftrightarrow \left \{
\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\8 x_2 =&4 y_2\\8 x_3 =&-y_1 + y_2 + 3 y_3\end{array}
\right.
$$
Lorem ipsum dolor $$$ Lorem ipsum dolor $$$. foo sit ame $ a = \{ b, c \} $ ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}