use strict;
my $str = 'Lorem ipsum dolor sit ame $ a = \\{ b, c \\} $ Lorem 100 \\$ ipsum
$$ \\left \\{
\\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\\\y_2 =&2 x_2\\\\y_3 =&x_1 - x_2 + 3 x_3\\end{array}
\\right.
\\Leftrightarrow \\left \\{
\\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\\\8 x_2 =&4 y_2\\\\8 x_3 =&-y_1 + y_2 + 3 y_3\\end{array}
\\right.
$$
Lorem ipsum dolor
$$ \\left \\{
\\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\\\y_2 =&2 x_2\\\\y_3 =&x_1 - x_2 + 3 x_3\\end{array}
\\right.
\\Leftrightarrow \\left \\{
\\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\\\8 x_2 =&4 y_2\\\\8 x_3 =&-y_1 + y_2 + 3 y_3\\end{array}
\\right.
$$
Lorem ipsum dolor $$$ Lorem ipsum dolor $$$. foo sit ame $ a = \\{ b, c \\} $ ';
my $regex = qr/(?:\s+\$\s*(?P<in_line>[^$]+?)\s*\$\s+|^\s*\${2}\s*(?P<bloc>(?:[^$]{2})*?)\s*\${2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}